Back to overview
Resolved

Service disruption — upstream network incident (recurrence)

Jun 17, 2026 at 10:57pm UTC
Affected services
Api
Databases

Resolved
Jun 18, 2026 at 12:35am UTC

Resolved. Our upstream provider restarted the affected systems and connectivity was restored at 00:31 UTC. All services have been operational since.

Post-mortem: between 22:55 and 00:31 UTC a recurring network fault at our cloud infrastructure provider isolated the database node that powers VoiceDock, making the API, dashboard and voice calls unavailable for roughly 1 hour and 36 minutes. This was the second occurrence of the same upstream fault within 24 hours. The node itself stayed healthy throughout and no data was lost; the outage was a loss of network connectivity, resolved once the provider restored the affected segment.

A single dependency should not be able to take the service down. We are accelerating two improvements already underway: relocating our backups to storage independent of the affected infrastructure, and removing the single point of failure in our data layer through geographic redundancy. We apologise for the disruption and are monitoring closely.

Updated
Jun 17, 2026 at 11:25pm UTC

The cause has been identified as a network fault at our upstream cloud infrastructure provider, the same fault that affected us earlier today. The provider's technicians are working on restoring the affected network segment. Our database node itself remained healthy but was unreachable at the network level, and no data has been lost.

Created
Jun 17, 2026 at 10:57pm UTC

We are investigating a renewed loss of connectivity to our database and API, affecting voice calls and the dashboard. This appears to be a recurrence of the earlier upstream network incident at our cloud infrastructure provider. We are working to restore service as quickly as possible.